AutoDPの無人運用の方法

アプリ開発に関する質問 AutoDPの無人運用の方法

  • このトピックには5件の返信、2人の参加者があり、最後にUG-Hにより2年、 8ヶ月前に更新されました。
6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • 投稿者
    投稿
  • #1744
    UG-H
    参加者

    お世話になります。

    AutoDPを使ってショールームの無人運用コンテンツを検討しています。

    AutoDPを動かしていてスクリーンセイバーになってしまうことはないでしょうか?
    また、スクリーンセイバーから人が来たら復帰して紹介を始めるようなことはできますか?

    #1745
    加藤@SPI
    参加者

    お世話になっております。

    AutoDPが稼働している間は、PoewrPointのスライドショーが常に
    表示されており、その状態ではスクリーンセーバーは起動しません。

    逆に、モニターとしてCRTを使う場合など、
    画面が固定では具合が悪い場合は、
    例えばPowerPointの1枚目と2枚目のスライドに
    異なる画像を貼り、それぞれのノートに以下のようなコマンドを書けば、
    スクリーンセーバーの代わりになるのではないかと思いますので、
    参考にして頂けますようお願いします。

    ———–
    (1ページ目)
    LABEL:wait
    WEVENT://////detect_face_move//detect_face_move

    (2ページ目)
    WEVENT://////detect_face_move//detect_face_move
    GOTO:wait

    (3ページ目)
    LABEL:detect_face_move
    P0:SG:いらしゃいませ
    (これ以降、プレゼン本体)
    ———–

    #1747
    UG-H
    参加者

    回答ありがとうございます。
    試してみます。

    #1751
    UG-H
    参加者

    回答頂いたコマンドでテストしているのですが、ページ1から人検知でいきなりページ3に飛んでしまいます。
    WEVENTのタイムアウトが利いていないのかと思い、SET_WEVENT_TIMEOUT:10を先頭に入れてみたのですが効果がありません。人検知中はイベント待ちになってしまうのでしょうか?1ページ目でタイムアウトして2ページ目に推移するような方法はありませんか?

    参考:1ページ目のコマンド

    SET_WEVENT_TIMEOUT:10  
    LABEL:wait
    WEVENT://////detect_face_move//detect_face_move

    *2ページ目、3ページは変更なし

    よろしくお願いします。

    #1752
    加藤@SPI
    参加者

    お世話になっております。

    テストで使用されているPaPeRo i は、実機でしょうか。
    それともシミュレータでしょうか。

    シミュレータの場合、WEVENTコマンドに動体検知時のラベルが指定されていると、
    WEVENTコマンドの実行を開始してから5秒後に、動体検知時のラベルにジャンプするように
    なっております。
    (動体検知したという状況が、シミュレータの機能では再現できない為、5秒経過により
    動体検知とみなすようにしております)

    もし、テストにシミュレータをお使いでしたら、以下の①、②のいずれかを
    試してみて頂けますでしょうか。


    1ページ目の
    SET_WEVENT_TIMEOUT:10

    SET_WEVENT_TIMEOUT:4
    に変更する


    1ページ目と2ページ目の
    WEVENT://////detect_face_move//detect_face_move
    を両方とも
    WEVENT://////detect_face_move
    に変更する。

    ①②のいずれかの修正を行って頂き、シミュレータで実行すると、
    PowerPointのスライドショーには1ページ目と2ページ目が交互に表示されます。
    この状態で、シミュレータの3D画面の右脇の上の方の「シミュレータ」という
    ボタンを押し、出現する枠の中の「顔」というボタンを押すと、スライドショーに
    3ページ目が表示されると思います。

    #1757
    UG-H
    参加者

    ご返事ありがとうございます。

    もともと頂いたコマンドでちゃんと動作できました。
    PPTに残っていた昔のコマンドが悪さをしていたようです。
    (良く確認せずスミマセン)

    引き続きよろしくお願いします。

6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • このトピックに返信するにはログインが必要です。